Sztereó hanganyagszerkesztés
Készítette: Gajdátsy Péter
Átdolgozta: Márki Ferenc
A következő gyakorlatok Márki Ferenc: Digitális hangfeldolgozás című elektromos jegyzetének ismeretére épülnek. A feladatok címei mellett található oldalszámok a jegyzet odavonatkozó részeit jelölik. A dokumentum az alábbi helyen érhető el:
http://vibac.hit.bme.hu/ > Dokumentumok > Elektronikus jegyzetek
Készítsenek egy saját munkakönyvtárat a DATA/USERS/HT201x könyvtárba, majd másolják át a DATA/Hangtechnikai Gyakorlat/3_sztereo_edit könyvtárat. A későbbiekben csak a saját könyvtárukban dolgozzanak!
Az 1-5. feladatokra egyenként kb. 10 perc áll rendelkezésükre, a 6-11. feladatokra kb. 20 perc jut, melyet jelentősen csak akkor lépjenek túl, ha valamelyik másikat sikerült gyorsabban befejezni.
Az editáláshoz az Adobe Audition szoftverét használják.
A feladatokat önállóan végezzék, kérdés esetén természetesen forduljanak a mérésvezetőhöz.
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 piktogramokkal megjelölt feladatokat elvégzés után mutassa be a mérésvezetőnek.

1. Vágás – editálás [9-10. old.]
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A következőkben az lesz a feladat, hogy a 1_edit.wav hangfájl elején lévő csendet vágjuk le kellemes hosszúságúra, mintha egy CD-n lévő szám lenne, valamint, a végére illesszünk be 2mp szünetet.

Vizsgáljuk meg – fülre és szemre egyaránt –, hogy nem maradt-e valamilyen hallható nyoma a vágásnak (pattanás)!
Megoldás:

Ehhez először keressük meg, hogy meddig tartson a kivágandó rész, azt jelöljük ki az egérrel majd a Delete vagy Backspace gombbal kitörölhetjük. Az újabb editáló szoftverek általában már figyelnek arra, hogy a kivágás széleit egy nullátmenethez húzzák, így nem lesz zavaró pattanás a hanganyagban. Nagyítson rá a kijelölés szélére és vizsgálja meg, hogy az nullátmenetnél van-e. Ha nem ott lenne, akkor kapcsolja be az „Edit > Snapping” menüben a „Snap to Zero Crossings” és az „Enabled” opciókat (avagy a „Preferences > Data” menüben az „Smooth delete/cut boundaries” opciót 1-2 ms értékkel). A nagyításhoz az ablak jobb alsó sarkában található nagyító ikonokat vagy az egér görgetőgombját használhatják.
A szünet beillesztéséhez használjuk a „Edit > Insert > Silence...” menüpontot! 
2. DC ofszet [10-12. old.]

Ahogy a jegyzetben olvashattuk, a digitális rendszereknél előfordulhat, hogy a rögzített jelben DC komponens van, azaz a jel átlagértéke nem nulla. Az editáló programban a hanganyag DC ofszet értékét a „Window > Amplitude Statistics” menüpontban tudjuk megtekinteni (ld. 1. ábra).


[image: image4]
Nyissák meg a 2_DC.wav fájlt, nézzék meg, hogy van-e benne DC komponens, majd javítsák ki, ha szükséges. („Effects > Amplitude and Compression > Normalize”)
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1. ábra. Statisztika ablak
3. Hangerőszabályzás [12-13. old.]

Időnként szükség van arra, hogy akár az egész fájlnak, vagy csak egy részének a hangerejét megnöveljük. Ehhez a „Effects > Amplitude and Compression > Amplify” eszközt fogjuk használni.
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Nyissák meg a 3_1_volume.wav fájlt, jelöljék ki a középén található halkabb részt és hozzák egy hangerőre a fájl többi részével!
Ahhoz hogy a hangfájl a lehető legjobban ki legyen vezérelve, illetve hogy több hangfájl hangereje megegyezzen a „Effects > Amplitude and Compression > Normalize” funkciót használjuk. Egy technikai szokásra hadd hívjam fel a figyelmet, a csúcskivezérlést -0.2dB-re kell beállítani, nem pedig 0dB-re. (Nevesebb hazai és külföldi kiadók lemezein így van beállítva.)
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Nyissák meg a 3_2_normalize.wav fájlt! A három egymás utáni szakaszt hozzák azonos RMS értékre és hallgassák meg, hogy ezután milyen a szakaszok egymáshoz viszonyított hangereje! Ügyeljenek a túlvezérlésre!


Végül normalizálják a hangfájlt úgy, hogy -0.2dB-s csúcskivezérlése legyen!

4. Fade in, fade out, (crossfade) [13-15., 17-19. old.]
Felvételeknél gyakran használt módszer, hogy a szám csendből indul, és lassan felhangosodik. Ezt nevezik fade-in-nek és gyakran használják élő felvételeknél, amikor valamilyen zajból indul a szám. Fade-out-nak azt nevezzük, amikor a szám vége lassan elhalkul. Végül, a crossfade azt jelenti, hogy két számot egymásra úsztatok, azaz az egyiket elkezdem halkítani, a másikat pedig ezzel együtt hangosítani.

[image: image8]
Az editáló programban nyissuk meg a 4_fade.wav fájlt. Hallgassuk meg az elejét és a végét. Ezután, az elején jelöljünk ki egy rövid szakaszt valahol 200ms és 3s között, majd próbáljuk ki a „Effects > Amplitude and Compression > Fade Envelope” különböző fade-in beállításait: linear, smooth, valamint egyedi görbét is készíthetünk a kijelölt szakasz fölé rajzolt sárga görbe szerkesztésével. Hallgassuk meg a különbséget.
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2. ábra. A „fade” ablak
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A fade-out gyakorlásához a fájl végén jelöljünk ki egy hosszabb részt, a kívánt hatástól függően kb. 3-10mp-et, majd úgyanúgy hallgassuk meg a „Effects > Amplitude and Compression > Fade Envelope” különböző fade-out beállításait.
A crossfade használatára most nem térünk ki részletesen. Az ajánlott jegyzetben részletes ismertetést találnak róla.

EZT ÚGY TŰNIK AZ ADOBE AUDITION CS6 MÁR NEM TÁMOGATJA:

Wavepad viszont igen
5. Kézi hullámforma javítás [15-17. old]
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Nyissa meg az 5_error.wav fájlt, keresse meg benne a pattanás jellegű hibákat és javítsa ki azokat kézzel! Ehhez a felső menüsorból a „Pencil tool”-t használja.
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3. ábra. Kézi hullámforma javítás ikonja

A legtöbb hangszerkesztő program rendelkezik automata zaj- illetve pattanásszűrő algoritmusokkal, és valószínűleg ezeket fogják majd használni egy-egy valódi probléma megoldásához. A gyakorlat rövidsége miatt azonban, ezek használatára most nem térünk ki, mivel nagyon sok paramétert kell beállítani egy-egy ilyen szűrésnél ahhoz, hogy jó eredményt kapjunk.
6. Tempó és hangmagasság-változtatás [17-22. old.]

Ehhez a feladathoz a 6_tempo_pitch.wav fájlt 
használják. A tempóváltoztatás és a hangmagasság-változtatás az „Effects > Time and Pitch > Strech and Pitch” menüpont alatt található.


[image: image13]
Vizsgálják meg, hogy a különböző hangszerek illetve beszéd hanganyagok milyen mértékű lassítást/gyorsítást illetve hangmagasság-változtatást viselnek el! Az utóbbinál külön vizsgálják, hogy mi a helyzet olyankor, ha a hangmagassággal együtt a tempót meghagyjuk vagy azt is megváltoztatjuk! Ez utóbbihoz a „Lock Stretch and Pitch Shift” opciót jelöljék be.


Próbálják ki a különböző algoritmusokat és figyeljék meg, hogy milyen különbségek vannak közöttük!

7. Mix készítés „ismeretlen szoftverrel” – Audacity/Wavosaur?
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A következő feladathoz térjenek át egy másik hangszerkesztő szoftverre: Adobe Audition-ra vagy a Steinberg cég WaveLab szoftverére. Ennek célja, hogy a már begyakorolt műveleteket függetlenül az adott szoftver menüelrendezésétől is képesek legyenek megvalósítani!


Válasszanak 3 jelentősen különböző stílusú számot (dolgozhatnak saját anyagból avagy a d:\Audio\MP3 könyvtárban található hangfileokból), vágjanak ki mindegyikből egy 10‑20 mp‑es jellemző részletet (pl. egy refrént), majd állítsák be – fül alapján – azonos hangerejűre a 3 számrészletet. Nézzék meg, hogy RMS értékben mennyire egyeznek a beállított hangfájlok hangerői. Változtassák meg legalább az egyik részlet hangmagasságát vagy tempóját úgy, hogy az a többihez illeszkedjék. Ezután vágják össze őket (crossfade) úgy, hogy az átmenet pattanásmentes, természetes legyen!
Effektezés:

A mérés második részében a hangtechnikában általánosan használt jelfeldolgozási módszerekkel, azaz effektekkel ismerkedünk meg. Először sztereó felvételeken gyakoroljuk a hangszínszabályzást, majd rátérünk a zengetők, késleltetők (delay) és a kórus effektek, végül a dinamika-szabályzók használatára.
A következő feladatok során az Effects alkönyvtárban található fájlokból válogassunk!
8. Hangszínszabályzás (Equalizing) [22-24. old.]
A hangszínszabályzás használatának különböző okai lehetnek. Például, egy autórádió esetén a hangszórók hiányosságait próbáljuk korrigálni mély és magas emeléssel. Egy felvétel vagy élő hangosítás során pedig inkább a művészi célból, egy bizonyos hangzás kialakítása miatt használjuk, illetve azért, hogy az egyes hangszereket frekvencia-tartományban elkülönítsük egymástól. Egy gyakorlati példa az utóbbira: általában a zongora és az akusztikus gitár mélyeit levágják, hiszen a zenében úgyis ott van a lábdob és a basszusgitár.

A hangszínszabályzóknak több fajtája ismeretes. A legfejlettebbeken a következő paramétereket tudunk változtatni:

· Kiemelés/vágás mértéke (gain/boost/cut)

· Frekvencia (frequency)

· Sávszélesség/jósági tényező (bandwidth/Q)

· Vágási karakterisztika: parametrikus avagy sáváteresztő (parametric/and-pass), alul-/felüláteresztő (low-/highpass), lyuk (notch), alul-/felülpolcoló avagy tehénfark (low-/high-shelv)

Az egyszerűbb megoldásoknál egy vagy két paraméter állandó értékre van beállítva. 

[image: image15]
A vicces_EQ.wav fájl hangszínét megváltoztattuk. Próbálja meg visszaállítani az eredetihez közeli, kellemes, természetes hangzást! (Az eredeti fájl az el_gitar.wav)

[image: image16]
Az Effects könyvtár hangfájlait használva végezzen három módosítást bármelyiken. Készítsen egy tompa, egy „Sokol rádió” és egy nagyon éles hangú változatot!

9. Zengetés (Reverb) [30-33. old.]
Egy teremben a forrás megszólalása után először a közvetlen, direkt hang jut el a fülünkig. Alapvetően ez határozza meg az irány és a hangszín érzetet. Ezt követik az ún. korai visszaverődések (early reflections), melyek a hangforrástól a fülünkig egy-két reflexión keresztül érkeznek meg. Ezek eloszlása és a direkt hanghoz való arányuk alakítja ki a teremérzetet. Fontos paraméter még az ITD: Initial Time Delay Gap  (effektekben inkább a pre‑delay elnevezéssel találkozunk, innen jön a magyar elnevezés: előkésleltetés). Ennek a hossza határozza meg, hogy mennyire érezzük magunkat közel a hangforráshoz. Ezután egyre több, egyre halkabb visszavert hang jut el a fülünkig, ezt nevezzük a zengési szakasznak. Ennek hossza befolyásolja a teremméret érzetét. (Ezt nevezik decay time-nak.)

Az effektek gyakran tartalmaznak egy „damping” nevezetű paramétert. Ez általában a magas hangú zengést csillapítja. Gyakran található egy külön paraméter a mély hangok csillapítására, ami által kevésbé lesz dübörgő a zengés.

[image: image17]
Válassza ki valamelyik fájlt, és virtuálisan helyezze el a hangforrást a következő terekben (az eredményeket külön fájlokban mentse el):
- Zengő, nagyméretű barlang, hallgató a forrástól nagyon távol

- Zengő, kicsi terem (fürdőszoba „feeling”), hallgató a forráshoz közel

- Kellemes hangú koncertterem, hallgató a forrástól közepes távolságban

- Közepes méretű szoba
A zengetéshez az „Effects > Reverb” menüpontban található zengetőt használják!

10. Visszhang (Delay, Echo)

Visszhangról, akkor beszélünk, ha elkülönült visszaverődések érkeznek legalább 50-80 ms időkülönbséggel. Amennyiben a visszaverődések időben túl sűrűn, egymáshoz túl közel érkeznek, akkor már nem visszhangról, hanem zengésről beszélünk.


[image: image18]
Gondolkozzon el azon, hogy milyen hatása van egy egyszeri visszaverődésnek, amely a direkt hanghoz képest csak néhány milliszekundumos (pl. 5 ms) késéssel érkezik meg! Mi történik, ha a késleltetés idejét kismértékben növeljük ill. csökkentjük!

Az iménti következtetéseinek ellenőrzésére vezesse le, hogy az eredő jel spektruma milyen lesz! A levezetéshez Fourier-transzformációt használjon! 


[image: image19]
A következőkben egy hangfájlon fogjuk megfigyelni a késletetés zenei alkalmazását, az „Effects > Delay/Echo > Simple/Multi-tap” funkciót használva!
Vizsgálja meg, hogy a késleltetési idő változtatásának milyen hatásai vannak! (legalább 3 szakaszt különböztessen meg és mutasson be!) Milyen késleltetési idő esetén lehet először érzékelni az elkülönülő visszhangot? 
11. Dinamikaszabályzók (Compressor, Limiter) [24-30. old.]
Egy kompresszor beállításához leggyakrabban négy paraméter áll rendelkezésünkre (ld. 4. ábra):
· küszöbszint (threshold)

· arány (ratio)

· megfogási idő (attack time)
· elengedési idő (release time)
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4. ábra. Dinamika komresszor
Jellemző, hogy a beállításokat grafikusan is ábrázolják. Ilyenkor jól látható, hogy milyen jelszinttől kezd el működni a kompresszor, valamint, hogy adott bemeneti jelszintváltozás mekkora kimeneti változást hoz létre.


[image: image21]
Vizsgálja meg és mutassa be a kompresszor és a limiter közötti alapvető különbséget!

[image: image22]
Növelje meg valamelyik példafájl hangerejét a lehető legjobban, anélkül hogy túlvezérelné, illetve, hogy jelentős hallható változást szenvedne a jel!
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Vizsgálja meg, hogy milyen hatásai vannak az egyes paraméterek változtatásának!

[image: image24]
Vizsgálja meg és jegyezze fel, hogy milyen beállítások ideálisak a különböző hangforrások számára:

- ének


- akusztikus gitár


- basszus gitár


- pergő dob


- lábdob[image: image25.wmf]
�további fájlok kellenek: beszéd, dob, gitár, stb.
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